From GnuCash
Jump to: navigation, search

aptitude or apt-get

apt-get build-dep gnucash failed for me. aptitude build-dep gnucash worked Seems like aptitude is more robust and the wiki should be changed.

This is distribution dependent and reference to specific package loading tools should be in the relevant distribution section. Also library names can sometimes vary from distribution to distribution as well

Ubuntu versions

fixing slib issues

On Ubuntu 10.04.1 the path for the guile.init file is a bit shorter than mentioned in the article:


Thus line 1790 in my slib.scm file reads:

(load-from-path "/usr/share/slib/guile.init")

hope that helps someone

Old Versions

twt writes: Every time I look at this page I think about ditching the information for the old Ubuntu versions -- as you can see from the wikipedia page link I added awhile back, most of the old ones are not even supported by security updates and any serious person wouldn't be running them EXCEPT maybe to build an old version of GnuCash. So the only reason to keep them around would be "collective memory" -- "that's how we solved (whatever problem), back in the day."

I was wondering if there's a page for old outdated stuff like that. Next time I drop by I will look for it. IF not, maybe I will make one. Twt

I think you can safely remove the old stuff - it is always still available through the history. --Cstim 09:39, 18 February 2011 (UTC)
Ok thanks... I see some "interesting bits" I would like to retain (creating a .deb using checkinstall, for example, and maybe some of the old tricks), but NEXT time I get a few minutes I will clean things up as I suggested. --Twt 16:40, 25 March 2011 (UTC)

Ok I finally deleted the old stuff, which leaves an orphaned wiki page: BuildGutsy When I get a chance and a fresh eye I will look over the instructions to make sure all parts been updated to assume git instead of svn. Twt 00:32, 6 February 2013 (EST)

Ubuntu 11.10: svn not found

On 2 November 2011 Phild wrote:

I was following the instructions for Ubuntu 11.10 which uses git, but during the "make" step I get an error almost immediately when it tries to run svn:

svn log -v --xml -r HEAD:20021 | \
	  xsltproc --stringparam strip-prefix "gnucash/trunk" \
	  --stringparam include-rev "yes" ./macros/svn2cl.xsl - > ChangeLog

/bin/bash: svn: command not found

I thought that since we were using git it wouldn't use svn. Any idea where I went wrong?

Don't Copy and Paste Instructions

TWT writes: I got a notice today -- 29 April 2014 -- that Clanlaw was here, who apparently said:

Note: Dear Ubunteros, please do not copy and paste whole paragraphs. Instead adjust single sections in the form

Version x and newer:
do this
Version x-1 and before:
do that.
Can someone of you clean up this chapter and later remove this note?

I like this suggestion -- in fact it looks like a lot of important hand-holding has been mixed in with the Ubuntu version-specific sections, and should be split out instead of making it look specific to Ubuntu. For example, the process for retrieving via git.

Also just about everything will be identical between Debian and Ubuntu, so those sections can probably be merged. I'm making notes here and will try to get back soon to make a few changes. If someone else reading this has other thoughts please feel free to write them here. --19:17, 29 April 2014 (UTC)

Note from Clanlaw, 01 May 2014. It was not me that said that. In fact I think it is important that this should be as simple as possible for someone who may not be that IT savy to understand. Remember that Ubuntu often has out of date versions of GnuCash and there needs to be simple instructions on how to build it. Any changes must not compromise that. Tidying up this document could make it more difficult to understand if not done carefully.

Building with make -jX

I had some trouble building gnucash for the past days and I couldn't for the life of me figure out why gnucash wouldn't build. I just added the -j2 options to try and speed up the compiling and when surfing around, this bug popped up:

Would it be a good idea to make a note somewhere in the building section to specifically mention that gnucash doesn't support the -jX (X>1) feature? --Bert 17:46, 24 May 2011 (UTC)

Ok, but please keep in mind this restriction applies only to the "make install" step, not the "make" step. --Cstim 06:56, 27 May 2011 (UTC)

1/5/2018 DaveC49

Added a breakout for building Gnucash-3.x on Ubuntu/Linux MInt (specifically 16.04) but should be generic for later versions.