Gentoo

From GnuCash
Jump to: navigation, search

via Portage

Both 2.0 and 1.8 are available in Gentoo. As of September 2006, 2.0.x is stable on x86 and amd64.

  • 2.0.x : official portage stable ebuild
  • 1.8.x : official portage stable ebuild

The 2.1.x release series are available via an ebuild in the gnucash sources.

Early 2007 problems with guile, slib, g-wrap and gnucash

Start at Gentoo Bug#158251, Comment#10, then figure out what the current resolution of that (and related bugs) is.

For GnuCash 2.0.x with OFX direct connect

Here is what you need, and the order is important:

  1. Make sure you libofx-0.8.2 or greater installed.
  2. Make sure you have aqbanking-2.2.1 or better with "USE=hbci" installed, and it has been rebuilt against libofx-0.8.2.
  3. Finally emerge gnucash-2.0.1 or better with "USE=ofx hbci"

Make sure you use the emerge option --oneshot when emerging the libraries so they're not added to your world list.

Problems

The following are some problems you (i did as of Sept. 9 2006) might run into:

Emerging libofx-0.8.2

This version or better of the package is necessary for OFX direct connect support. As of current speaking (see above) this package is not available in Portage. So you will have to use an custom overlay ebuild. If you're unfamiliar with how to setup an portage overlay, see the Gentoo Handbook's section on adding unoffical ebuilds for full details; a short summary is here:

  • Emerge the current available version of libofx, which currently is libofx-0.8.1-r1
  An ebuild for 0.8.2 can be found here: http://bugs.gentoo.org/show_bug.cgi?id=146408
  • Create the following directory
  $ mkdir -p /usr/local/portage/dev-libs/libofx
  • Make portage aware of your overlay directory
  $ echo 'PORTDIR_OVERLAY=/usr/local/portage' >> /etc/make.conf
  • Copy libofx-0.8.1-r1 e-build and patches to new overlay directory
  $ cp -R /usr/portage/dev-libs/libofx/libofx-0.8.1-r1.ebuild /usr/local/portage/dev-libs/libofx/libofx-0.8.2.ebuild
  • Finally copy any patches (you proboably will not need these but just in case)
  $ cp -R /usr/portage/dev-libs/libofx/files/* /usr/local/portage/dev-libs/libofx/files/
  • Make a digest
  $ ebuild /usr/local/portage/dev-libs/libofx/libofx-0.8.2.ebuild digest

Now edit the ebuild libofx-0.8.2.ebuild.

Look for a line at the top of the file that looks like this (you might not have it):

  inherit utils

If this line exists, comment it out. The line tells the e-build to apply patches, and it is highly likely you don't need it (more below).

  #inherit utils

Now look for the src_unpack routine. Note it could be a little different, note the last three lines before the brace, that means a patch was applied. The src_unpack routine in my case looked like this.

   src_unpack() {
     unpack ${A}
     # because we redefine docdir in src_install, we need to make sure the
     # dtd's go to the right place, LIBOFX_DTD_DIR
     cd "${S}"/dtd
     sed -i -e 's/$(DESTDIR)$(docdir)/$(DESTDIR)$(LIBOFX_DTD_DIR)/g' \
          Makefile.in
     cd "${S}"
     # bug 116208
     epatch "${FILESDIR}"/${P}-tree.diff
   }

It is highly probable that the patch is included in the latest software version so, comment out the last three lines.

   src_unpack() {
     unpack ${A}
     # because we redefine docdir in src_install, we need to make sure the
     # dtd's go to the right place, LIBOFX_DTD_DIR
     cd "${S}"/dtd
     sed -i -e 's/$(DESTDIR)$(docdir)/$(DESTDIR)$(LIBOFX_DTD_DIR)/g' \
          Makefile.in
     #cd "${S}"
     # bug 116208
     #epatch "${FILESDIR}"/${P}-tree.diff
   }

Save the e-build file, if you made any changes. NOTE: If you made any changes to the e-build file run the digest command again.

   $ ebuild /usr/local/portage/dev-libs/libofx/libofx-0.8.2.ebuild digest

Now just emerge libofx and you should be upgraded 0.8.2

   $ emerge --oneshot libofx

Emerging aqbanking 2.2.1

The package aqbanking-2.2.1 and its dependencies (gwenhywfwar-2.4.0 AND ktoblzcheck-1.11) are currently marked unstable in portage.

As of Oct 10 2006, aqbanking-2.2.1 is not marked unstable; check the current state of the world before following these instructions, as the keyword markings below are relatively broad in effect. --- jsled

So to get it add these lines to /etc/portage/package.keywords before you emerge aqbanking.

    $ echo 'net-libs/aqbanking ~x86' >> /etc/portage/package.keywords
    $ echo 'sys-libs/gwenhwywfar ~x86' >> /etc/portage/package.keywords
    $ echo 'app-misc/ktoblzcheck ~x86' >> /etc/portage/package.keywords