De/FAQ

From GnuCash
Jump to: navigation, search

Zurück zur Hauptseite

Diese Seite ist "work in progress"

Dies ist der Beginn einer Übersetzung der englischen FAQ's, ergänzt durch typisch deutsche Fragen. Die Inhalte dieser FAQ sollen gelegentlich in die GnuCash-Dokumentation

HTML englisch deutsch
'Guide' gnucash-guide 2.6

guide Git

GnuCash Tutorial and Concepts Guide 2.6

Kurs und Konzepte Git

Hilfe gnucash-help 2.6

help Git

GnuCash Hilfe 2.6

GnuCash Hilfe Git

andere Formate:

epub, mobi, pdf

browse 2.6

browse Git

browse 2.6

browse Git

einfließen. Git ist die aktuell in Arbeit befindliche Version. Wenn da jemand einen Fehler eingebaut hat, kann es sein, daß sie nicht erreichbar ist. Dann sollte man auf die etwas ältere stabile Version zurückgreifen.

Falls man hier in der deutschen FAQ nicht fündig wird, bitte in der meist aktuelleren englischsprachigen FAQ weitersuchen!

Contents

Allgemeine "Häufig gestellte Fragen" (FAQ) über GnuCash

F: Wo bekomme ich Hilfe zu GnuCash?

A: Es gibt folgende Möglichkeiten:
Dokumentation
Es gibt zwei Dokumente, "Kurs und Konzepte" sowie "Hilfe", die hier teilweise auf Deutsch verfügbar sind: http://www.gnucash.org/docs.phtml?lang=de_DE
Bei vielen Distributionen können diese als Paket gnucash-doc o.ä. installiert und dann direkt aus dem Programm heraus aufgerufen werden, sofern auch das GNOME-Hilfe-Programm Yelp installiert ist.
Wiki
Auf diesen Wiki-Seiten hier kann jeder neue Informationen einfügen. Die aktuelleren findes sich aber meist auf den englischen Seiten.
Mailing-Liste
Es gibt eine deutschsprachige Mailingliste (d.h. ein E-Mail-Forum), wo auf Deutsch alle Fragen gestellt werden können und die meisten Antworten gegeben werden. Man sollte sich auf der Mailingliste hier anmelden und kann anschließend an die Adresse gnucash-de@gnucash.org eine E-Mail mit der Frage schicken. Emails von Nicht-Abonennten müssen wegen möglicher Spam-Mails erst von einem Moderator freigegeben werden, was schon mal einen Tag dauern kann. Abmeldung ist natürlich jederzeit wieder über obigen Link möglich. Einige weitere Tips dazu gibt es in De/Referenz#Auf_der_Mailingliste.
Im GnuCash-Projekt gibt es auch viele anderssprachige Mailinglisten. Eine Übersicht gibt es auf Mailing Lists.
Chat
Es gibt für schnelle Rückfragen auch einen Chat-Kanal #gnucash in irc.gimp.org. Dort wird aber in erster Linie englisch gesprochen. Details zu IRC finden sich auf der englischen Seite, eine deutschsprachige FAQ zu IRC auf IRC-FAQ.de.

F: Wie kann ich zum GnuCash-Projekt beitragen?

A: Dies wird detailiert auf englisch in Contributing to GnuCash erläutert.
  • Gib deine Erfahrungen weiter:
  • Berichte deinen Freunden oder in deiner örtlichen LUG von deinen Erfahrungen.
  • Ergänze dies Wiki und hilf, es aktuell zu halten. Einfach rechts oben anmelden und loslegen.
  • Wenn du englisch kannst:
  • Hilf anderen Benutzern im IRC
  • An der Lokalisierung (englisch) mitwirken, z.B. durch Ergänzung der deutschen Hilfe oder des Guides oder der deuschsprachigen Kontenrahmen oder der Steuerberichte.
  • Programmieren:
GnuCash hat viel Code in C und Scheme (siehe auch Developing GNUCash: Source Code Overview). Daneben gibt es eine Python-Schnittstelle. Wenn Du diese Programmiersprachen nicht beherrschst, kannst Du sicher in anderen Bereichen etwas beitragen.
und dort schreiben, was Du zur Entwicklung von GnuCash beitragen kannst.

F: Wie kann ich an das GnuCash Project spenden?

A: Dies wird in Spenden erläutert.
Contributing to GnuCash#Money enthält den englischen Originaltext.

F: Wie kann ich erreichen, dass GnuCash ein neues Feature XYZ bekommt?

A: Das wird auf der englisch-sprachigen Seite Bugzilla erläutert. Der Trick dabei ist, es so zu beschreiben, daß es der Programmierer versteht und noch besser, daß er beim Lesen motiviert wird, es zu programmieren.
Wenn man des Englischen nicht mächtig ist, sollte man seinen Vorschlag auf der deuschen Mailingliste oder unter Uservoice einreichen und um Unterstützung bitten.
Wenn man das Programmieren beschleunigen möchte, sollte man über eine Belohnung wie hier beschrieben, nachdenken.
Am allerschnellsten bekommt man das Feature aber, wenn man es selbst schreibt. Ein Patch ist immer willkommen und wird gerne in der nächsten Version mit aufgenommen.
Wünsche kann man aber auch auf der Projektseite eintragen. Die englische gibt es hier.

Installation

GnuCash allgemein

F: Welche Dateinamenserweiterung benutzt GnuCash?

A: GnuCash erzwingt keine bestimmte Dateinamens-Konvention, folgende Erweiterungen sind allerdings vordefiniert im Paket "shared-mime-info", das es für fast jede Linux-Distribution gibt. Unter Windows wirkt ein anderer Mechanismus. Dateien, die diese Erweiterungen tragen erlauben es, dass GnuCash gestartet wird, wenn man in einem Dateibrowser diese Dateien öffnet:
  • .gnucash (empfohlen)
  • .gnc - die "interne" Drei-Buchstaben-Abkürzung von GnuCash
  • .xac - kurz für "X-Accountant", dem Vorgänger von GnuCash. Diese Erweiterung wird immer noch standardmäßig für die Backup-Dateien verwendet.

F: Gibt es eine Datenbank-Anbindung?

A: Es gab mal eine Postgresql-Anbindung, die mit Version 1.6 eingeführt wurde. Diese wurde aber durch DBI ersetzt. Damit stehen seit der Entwicklerversion 2.3 folgende 'Backends' zur Verfügung:
  • XML: die eXtended Markup Language hat sich seit Jahrzehnten in GnuCash bewährt und erstellt mit den Voreinstellungen automatisch Backup-Dateien.
  • SQL: die genormte Structured Query Language - Strukturierte Abfrage-Sprache für Datenbanken kann z.B. aus Libre-/OpenOffice heraus abgefragt werden. Das Erstellen von Sicherheitskopien liegt hier aber in der Verantwortung des Anwenders.
    • SQLite: SQL für Heimanwender, da für die Datensicherung weiterhin nur eine Datei gesichert werden braucht.
    • professinelles SQL erfordert gewisse Administrationskenntnisse des jeweiligen DatenBankManagmentSystems:
      • MySQL oder Fork MariaDB: weit verbreitet, da für Webserver entwickelt und auf Geschwindigkeit optimiert,
      • PostgreSQL: seit Jahrzehnten entwickelt mit nahezu allen Merkmalen, die das Programmiererherz höher schlagen lassen.
Zur Datensicherung muss man in beiden Fällen einen Dump erstellen.
Siehe auch SQL-Datenmodell.

F: Wie kann man die Anzahl der Konten oder Transaktionen in einer GnuCash-XML-Datei bestimmen?

A: zcat $DATAFILE | grep -c "act:name"
für die Konten.
Falls man die Datei unkomprimiert gespeichert hat, entfällt "|" und alles was davor steht.
Ersetze 'grep -c "trn:desc"', um die Anzahl der Transaktionen zu bestimmen. [1]
Selbstverständlich ist $DATAFILE durch den entsprechenden Dateinamen zu ersetzen.

F: Wie viel Speicherplatz sollten in etwa meine Anwenderdaten einnehmen?

Meine Daten belegen 49MB und ich kann mir nicht vorstellen, warum das soviel Speicherplatz kostet. Lässt sich das komprimieren oder "aufräumen" ?

A Prüfe unter Bearbeiten->Einstellungen->Allgemein das die Option 'Datei komprimieren' ausgewählt ist. YeOldHinnerk (talk) 13:29, 9 March 2015 (UTC)
A: Ich komme auf 3MB für zwei Jahre an Daten und einige tausend Buchungen. Aufräumen oder komprimieren ist bisher nicht möglich. Helfen würde nur ein manueller Abschluss der Bücher und neu eröffnen in einer anderen Datei. In der experimentellen Version wird an einem automatischen Jahresabschluss gearbeitet, aber dauert noch Monate, bis dieses Feature benutzbar ist. -- ChristianStimming 2003-08-22T14:05:23Z
A: Vielleicht liegt es auch daran, dass bei jedem Speichern eine Sicherheitskopie der alten Datei angelegt wird. Alte Sicherheitskopien können regelmäßig gelöscht (oder besser archiviert) werden. -- BennySiegert 2003-08-22T17:05:00Z

F: Wieso bekomme ich die Meldung "Missing charsets in FontSet creation"?

Bei SuSE 9.0 ist die Version 1.8.7 (nach update) dabei, bei einem Startversuch (KDE) kommt aber immer:

    Gdk-WARNING **: Missing charsets in FontSet creation
    Gdk-WARNING **:     ISO8859-15
    Gdk-WARNING **:     ISO8859-15
    Fatal Error: gnucash_style_set_register...(): Cannot load
fallback font: -adobe-helvetica-medium-r-normal--*-120-*-*-*-*-*-*
A:Hab's selber gefunden:
YaST > System > Editor für /etc/sysconfig-Dateien
System > Console > Framebuffer > CONSOLE_ENCODING
ISO-8859-15 ändern in ISO-8859-1

das war's. -- Andreas Horn <<MailTo(andreashorn AT gmx.de)>>

F: Fehlermeldung "slib:require unsupported feature format" unter Debian Sid?

... Bei Debian Sid kam es durch ein Update von slib <3 auf >3 eine zeitlang zu den Fehler:

bash-2.05b$ gnucash
Backtrace:
In unknown file:
...
In /usr/share/gnucash/guile-modules/gnucash/report/iframe-url.scm:
7: 54* [require format]
In unknown file:
?: 55  (cond ((not feature) (set! *catalog* #f)) ((slib:provided? feature)) ...)
...
?: 56  [scm-error misc-error #f ...]
<unnamed port>: In procedure scm-error in expression (scm-error (quote misc-error) #f ...):
<unnamed port>: slib:require unsupported feature format
A: Dieser Fehler kann durch die Installation neuerer Pakete von gnucash (1.8.8-7 oder höher) behoben werden. Wenn diese nicht zur Verfügung stehen, dann sollte die ältere slib durch den Befehl "apt-get install slib=2d4-2" installiert werden. Siehe dazu auch den Bugreport: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=238106

F: Ich benutze KDE und möchte die Fonts ändern

A: GnuCash benutzt die GNOME Umgebung, auch wenn man KDE benutzt. Die Fonts kann man im gnome-control-center einstellen.

F: Wie kann ich Finance::Quote überprüfen?

A1: Erst einmal die installierte Version feststellen. In der Konsole: gnc_fq_check aufrufen. Die Version wird gleich an der ersten Stelle angezeigt. Hier im Beispiel 1.13.
user@rechner:~$ /usr/bin/gnc-fq-check
("1.13" "tsp" "vwd" "financecanada" "yahoo_nz" "australia" "usa" "troweprice" "france" \\
"amfiindia" "nasdaq" "usfedbonds" "bmonesbittburns" "aex_options" "yahoo_asia" "troweprice_direct" \\
"tiaacref" "canada" "yahoo" "seb_funds" "yahoo_brasil" "fidelity" "aiahk" "greece" "dwsfunds" \\
"yahoo_australia" "unionfunds" "finland" "lerevenu" "asia" "indiamutual" "hex" "brasil" "asegr" \\
"deka" "nyse" "canadamutual" "fidelity_direct" "asx" "tdwaterhouse" "fool" "trustnet" \\
"ftportfolios_direct" "uk_unit_trusts" "dutch" "ftportfolios" "tdefunds" "nzx" "za" "aex_futures" \\
"fundlibrary" "stockhousecanada_fund" "aex" "yahoo_europe" "nz" "vanguard" "bourso" "europe" \\
"platinum" "maninv")
A2: Wenn die Ausgabe ohne Fehler ist, am besten weiterfahren mit einem Abruf. Beispiel zum Abruf eines yahoo kurses:
user@rechner:~$ echo '(yahoo "CSCO")' | gnc-fq-helper
(("CSCO" (symbol . "CSCO") (gnc:time-no-zone . "2009-02-11 13:30:00") (last . 16.09) (currency . "USD")))

Hierbei ist yahoo eine Datenquelle aus der vom gnc-fq-check-Aufruf zuvor gelieferten Liste und CSCO (=US-Tickersymbol von Cisco) das Symbol. Diese kann man auch durch eigene Werte ersetzen. Die Antwort übersetzt:

Am 11.02.2009 um 13:30 (Zeitzone nicht angegeben) war der letzte Kurs 16,09 in der Währung US-Dollar.

F: Warum ist GnuCash von GNOME abhängig?

A: GnuCash benutzt die GNOME-libraries für die folgenden funktionen:
  • drucken (gnomeprint)
  • konfiguration (gconf)
  • grafik (goffice)
  • User-Interface (libgnomeui)
  • HTML-Darstellung (gtkhtml / html-reendering)
  • Hilfe (yelp)


Die Entwickler wollen sich mehr auf die eigentlichen Finanzfunktionen konzentrieren als dass sie Energie in Funktionen stecken die es schon gibt.
Man muss auch nicht den kompletten GNOME-Desktop installieren um GnuCash zu verwenden.

GnuCash unter Windows

F: Beim starten bekomme ich einen Fehler wegen corba-object.c und GnuCash bricht ab

A: Die genaue Fehlermeldung ist: OTHER <> file corba-object.c: line 76 (ORBit_register_objref): assertion failed: (obj->object_key != NULL)
Das ist bereits gemeldet unter: [http://bugzilla.gnome.org/show_bug.cgi?id=457841| http://bugzilla.gnome.org/show_bug.cgi?id=457100 http://bugzilla.gnome.org/show_bug.cgi?id=457841 ]. Die empfehlung ist das löschen der Verzeichnisse unter c:\Documents and Settings\Username
  • ~/.gconf
  • ~/.gconfd
  • ~/.gnome2
  • ~/.gnucash


F: Kann ich eine neue GnuCash-Version über die alte hinweg installieren?

A:Ja, es geht. Man muss die alte Version nicht vorher deinstallieren. Auser:
wenn man von 2.1.x nach 2.2.x updated. Dann wird ein deinstallieren von 2.1.x erforderlich.

F: Warum werden beim Installieren unter Windows alle DLLs im GnuCash Verzeichnis untergebracht?

'A: GnuCash ist abhängig von etwa 50 DLLs. Um nicht andere Programme zu beeinflussen, haben die Entwickler alle DLL's in ein einziges Verzeichnis gepackt, auch solche die bereits unter ...\system32 schon vorhanden sind.


GnuCash unter Mac OS

F: Wie installiert man GnuCash unter Mac OS?

A1: Siehe Installation
A2: Siehe deutschspachiges Apfelwiki.
A3: Siehe englisches Wiki. Das besondere ist, dass hier auch Entwickler Beiträge einbringen.

GnuCash Dateien und Pfade

F: Wo speichert GnuCash meine Daten und Einstellungen?

A1: Daten werden abhängig vom Backend abgelegt. Dieses wird beim Speichern durch das 'Dateiformat' von dem Benutzer festgelegt.
  • postgres oder mysql: Für diese Backends gibt es keine Datei, sondern eine Datenbank in einem DBMS. Eine Datensicherung sollte entsprechend der Dokumentation der Datenbank erfolgen.
  • sqlite oder das klassische xml-file Format: Die Datei hat die Endung '.gnucash', sofern der Benutzer dies nicht geändert hat. Sie befindet sich in dem Verzeichnis, das der Benutzer beim Speichern ausgewählt hat.
Tipp 1: GnuCash öffnet normalerweise die zuletzt verwendeten Daten automatisch. Der Dateiname steht dann in der Titelzeile des GnuCash-Fensters. Beim Datei->Speichern unter -Dialog wird das zuletzt verwendete Verzeichnis angezeigt.
Tipp 2: Falls der Verlauf irgendwie verloren ging, durchsuche deine Speichermedien nach Dateien mit den Endungen .gnucash, .gnc und .xac.
Tipp 3: Die Dateien sind meistens komprimiert. Dieses läßt sich unter Bearbeiten->Einstellungen->Allgemein ändern.
A2: Einstellungen sind im .gnucash-Verzeichnis abgelegt. Dieses Verzeichnis befindet sich im Home-Verzeichnis des jeweiligen Benutzers. Wo das Home-Verzeichnis ist, ist wiederum abhängig vom Betriebssystem:
Betriebssystem Pfad zum .gnucash Verzeichnis
Linux/Unix .gnucash in Ihrem Home-Verzeichnis
Windows Vista, Win7 und neuer C:\Benutzer\'Benutzername'\.gnucash
Windows XP C:\Dokumente und Einstellungen\'Benutzername'\.gnucash
OSX Bundle (Gnucash.app) Library/Applications Defaults/Gnucash oder Library/Applications Support/Gnucash (Lion) in Ihrem Home-Verzeichnis

F: Wie lautet die Dateiendung für GnuCash?

A: GnuCash hat keine festgelegte Endung, aber seit Windows unterstützt wird, wird normalerweise .gnucash verwendet. Zuvor waren .gnc und .xac - letzere vor allem für Sicherungsdateien - üblich. .xac kommt von GnuCashs Vorläufer X-Accountant.

F: Wo finde ich die logfiles und wofür brauche ich die?

A: Im selben Verzeichnis, wo auch die Daten abgelegt sind. Sie so benannt:
<daten>.JJJJMMTTSSMMSS.log
Beispiel:
gnucash.20090227223211.log
Sollte GnuCash abstürzen, kann man versuchen, die verlorene Arbeit durch den Import der letzten Log-Datei wiederherzustellen, aber: die Datei enthält nur "normale" Transaktionen, komplexere Vorgänge (Geschäftsmodul) oder Änderungen an der Kontenhierarchie fehlen, was dann zum Teil zu verblüffenden Ergebnissen führen kann.

F: Wo finde ich meine Berichte mit den angepaßten Optionen?

A: In der Datei unter: saved-reports-2.0
Die Datei ist bei den anderen Einstellungen abgelegt (siehe oben).

F: Wie kann ich meine GnuCash-Daten sichern?

A: Das hängt wieder vom verwendeten Backend ab:
  • Falls du das vorgegebene XML verwendest, erstellt Gnucash regelmäßig beim Speichern ein Backup , indem es die vorherige Version, durch Einfügen eines Zeitstempels der Form JJJJMMTThhmmss zwischen Name und Erweiterung, umbenennt. Beispiel:
MeineFinanzen.gnucash wird zu MeineFinanzen.gnucash.20140131150812.gnucash.
  • Bei verwendung von SQLite, sollte man regelmäßig, ggf. von einem Hintergrunddienst gesteuert, Kopien erstellen.
  • Bei Verwendung von MySQL oder Postgresql sollte entsprechend den Empfehlungen des jeweiligen Handbuchs seinen SQL-Server sichern.
  • Weiterhin empfehlen wir, auch auf anderen Medien (Festplatten-Crash) und an anderen Orten (Gebäudebrand) möglichst verschlüsselte Sicherungen abzulegen. Dafür bieten sich u.a. verschiedene Internet-Dienste an: DropBox, Google Drive, or Carbonite, or Comodo Backup, vielleicht auch dein Internetprovider. Die NSA und ähnliche Behörden speichern zwar auch sehr zuverlässig, allerdings ist es äußerst schwierig, die Daten von dort wieder zurück zu übertragen.

F: Wie kann ich meine Gnucash-Einstellungen sichern oder auch ändern?

A: Als Erstes solltest du natürlich #F: Wie kann ich meine GnuCash-Daten sichern? ausgeführt haben. Eine Sicherung der Backup- und Protokoll-Dateien ist nicht unbedingt erforderlich.
Für die Einstellungen sichere
  • $HOME/.gnucash - angepaßte Berichte etc.
    • bzw. $HOME/Library/Application Support/Gnucash unter MacOS X,
Für einen anderen Teil - Verlauf, Werte aus Bearbeiten->Einstellungen, ... - wird seit GnuCash 2.6 - wie in Gnome 3 - Gsettings verwendet, zuvor kam GConf zum Einsatz.
  • GSettings basierte Einstellungen (GnuCash 2.6 und neuer) - Wie man diese sichert hängt von der Plattform ab:
  • Linux und ähnliche: GSettings verwendet dconf als Backend. Mit dem dconf Tool kann man alle Präferenzen auslesen:
dconf dump /org/gnucash/
  • Zum Bearbeiten eignen sich der DConf-Editor dconf-editor oder das Gnome 3 Kontrollzentrum gnome-control-center.
  • Windows: Gsettings verwendet die Windows-Registrierungsdatenbank. Man kann ein Backup vom Zweig HKEY_CURRENT_USER/Software/GSettings/org/gnucash/ mithilfe des Registry Editors regedit machen.
  • OS X: GSettings verwendet das systemeigene Defaults. Mit dem defaults-Tool kann man alle Gnucash-Einstellungen auslesen:
defaults read --app Gnucash
  • GConf basierte Einstellungen (GnuCash 2.4 und älter)
Die GConf-Einstellungen befinden sich in $HOME/.gconf/apps/gnucash/
Schließlich, falls De\AqBanking fürs Onlinebanking verwendet wird,
  • $HOME/.[aq]banking - enthält die Bankverbindungen, Protokolle etc. In älteren Versions hieß es .banking doch .aqbanking ist der aktuelle Name.
Microsoft Windows Anmerkung: $HOME bedeutet %SYSDRIVE%\Documents and Settings\%USER%\. Wenn z.B. das System auf Laufwerk C: installiert wurde und der Benutzername "foo" lautet, ist $HOME C:\Documents and Settings\foo, und das GnuCash Konfigurationsverzeichnis befindet sich in C:\Documents and Settings\foo\.gnucash.

Bedienung

F: Gibt es einen Weg die Buchungen von einem Konto in ein anderes zu transferieren?

A1: Man löscht einfach das Konto mit den Buchungen. Dann fragt GnuCash was mit den verbleibenden Buchungen geschehen soll und bietet an, diese in ein anderes Konto zu verschieben.
A2 Die zweite Alternative, für den Fall, dass man nur bestimmte Buchungen verschieben möchte. Man lässt sich die Buchungen im Split-Modus anzeigen. Dann geht man eine nach der anderen durch. Im Konto-feld kann man die Kurzschreibweise benutzen. Zum Beispiel Ausgaben:Auto:Reparatur, man kann dies auch abkürzen durch: Aus:Au:Re. Das ist aber nur eine Möglichkeit, wie man weniger tippen muss.
A3 Die dritte Alternative, auch die Riskanteste, ist es die Datei mit einem XML Editor zu öffnen. Man beachte, dass man sich die gesamten Konten zerschießen kann.

F: Wie kann man die geänderten Optionen eines Berichts dauerhaft speichern?

A: Wenn man einen Bericht offen lässt, während man GnuCash beendet, wird er beim nächsten Start mit den gleichen Optionen wiederhergestellt. Ab Version 1.8.10 gibt es außerdem in der Werkzeugleiste den Knopf "Bericht sp." (kurz für "Bericht speichern"), mit dem der aktuelle Bericht gespeichert werden kann und ab dem nächsten Programmstart als neuer Menüpunkt unter Berichte -> Benutzerdefiniert erscheint. -- ChristianStimming 2004-12-07T10:26:05Z


F:Gibt es auch deutsche Kontenrahmen und -bezeichnungen?

Ich habe GnuCash für Windows auf deutsch installiert. Alle Texte und Fenster werden in deutsch dargestellt. Nur die Kontenbezeichnungen sind englisch. Was muss ich tun um diese auch auf deutsch umzustellen?

A: Für die Spracheinstellung ist die Umgebungsvariable LANG zuständig. Sie muss für GnuCash zwei Informationen enthalten. Erstens die Sprache und zweitens die Lokalisierung, also z.B. LANG=de_DE für deutsche Sprache und deutsche Konten oder LANG=de_AU für deutsche Sprache und Östereichische Konten.
A: Die Umgebungsvariablen können in der Systesteuerung unter "System/Erweitert" für jeden User einzeln oder die ganze Maschine (nur Admins) gesetzt werden. -- BernhardWangler

F: Wie stelle ich die Sprache in meinem englischen GnuCash auf deutsch um?

Ich habe Version xy/ Betriebssystem xy und da ist ein englisches GnuCash dabei. Auf http://www.gnucash.org/ steht, dass es auch eine deutsche Lokalisierung gibt. Aber wo kann ich sie runterladen und wie stelle ich die Sprache in meinem englischen GnuCash um?

A: Es gibt auf allen Betriebssystemen die deutsche Version und eine Reihe weiterer Sprachen. Man muss dies halt nur aktivieren. Für die verschiedenen Betriebssysteme und verschiedenen Versionen steht das auf Englisch hier: Locale Settings

A: Die mitgelieferte Version von SuSE 9.1 enthält auch die deutsche Übersetzung. Die Umgebungsvariable LC_ALL oder LANG muss dazu auf so was wie de_DE gestellt sein (diverse Zusätze sind erlaubt). Also: Auf der Kommandozeile eingeben LANG=de_DE gnucash und sehen, was passiert (oder diesen Wert schon in der Systemkonfiguration einstellen. Bei z.B. Fedora Linux Core 3 steht das dann in /etc/sysconfig/i18n). -- ChristianStimming 2004-09-20T09:27:16Z

A:Bei Debian/Ubuntu ist evtl. nur das Sprachpaket de_DE.UTF-8 installiert. Dann muss einfach mit:

dpkg-reconfigure locales

noch das Sprachpaket de_DE nachgeladen werden. -- AlterDepp 2006-01-13T23:12:00Z --helmutundarnold 11:13, 20 October 2008 (EDT)


A: Unter Ubuntu 13.04 das auf English lauft hab ichs mit

LANGUAGE=de_CH.UTF-8 LANG=de_CH.UTF-8 LC_ALL=de_CH.UTF-8 gnucash
geschafft

F: Wieso wird die Hilfe nicht gefunden?

A: Die GnuCash Hilfe befindet sich in einem extra Paket gnucash-docs. Falls man beim Anklicken des Menüpunktes "Hilfe->Hilfe" die Fehlermeldung erhält "Nicht gefunden -- Die angegebene URL konnte nicht geladen werden", wurde dieses Paket noch nicht installiert. Man muss dann dieses Paket gnucash-docs noch zusätzlich installieren.


F: Wie kann man seinen Kontenbaum umbauen, bzw. die Sortierreihenfolge verändern?

A1: Mit "Konto bearbeiten" und dann für das Konto ein neues "Überkonto" auswählen. Damit kann man nur die Zuordnung im Kontenbaum verändern.
A2: Man lässt sich wie bei den Datev-Kontenrahmen eine Zahlen-Kombination für jedes Konto einfallen und beginnt den Kontennamen damit. Im Hauptfenster kann man die Sortierreihenfolge durch Mausklick auf die Spaltenüberschrift bestimmen.
A3: Wie A2, jedoch gibt man die Kontonummer im Feld Kontonummer an und kann dann wahlweise numerisch nach Kontonummer oder alphabethisch nach Kontobezeichnung auf- und absteigend sortieren, indem man auf die jeweilige Spaltenüberschrift ein- oder mehrmals klickt.

F: Wie kann man die Transaktionen innerhalb eines Kontos sortieren, besonders wenn viele mit dem gleichen Datum sind?

A: Die Standardsortierung basiert auf dem Eingabedatum der Transaktion, gefolgt vom Nummernfeld. Empfohlen wird hier, das Nummernfeld mit heran zu ziehen. Dann werden die Transaktionen entsprechend sortiert dargestellt.


Q: Gibt es einen Buchabschluss?

A: Seit Version 2.2.4 gibt es dafür einen Menupunkt Werkzeuge > Buchabschluss.

Für die Versionen davor gibt es verschiedene Alternativen, leider mit einem nicht unerheblicher Aufwand.

  • Eine einzige Datei für jedes Jahr: Am Ende des Jahres exportiert man den Kontenrahmen in eine neue Datei. Nun muss man noch die Kontostände aus dem letzten Jahr in die neue Datei übertragen.
  • Unterkonten mit der Jahreszahl: Ein andere Methode ist es die Ein- und Ausgabekonten mit der Jahreszahl zu versehen. Also
    Einkommen:2009

    Einkommen:2008
    ...
    Ausgaben:2009
    Ausgaben:2008
    ...
    Vorteil ist, dass beim Eingeben das Automatische Vervollständigen die bisherigen Buchungen mit berücksichtigt. Nachteil ist, dass es bei Berichten die über die Jahresgrenze hinausgehen immer nur Teilergebnisse anzeigt werden.

  • jGnucashEditor: Es gibt ein third party tool jGnucashEditor das es ermöglicht eine Buchungsdatei zu einem beliebigen Datum in zwei Dateien zu splitten. Das besondere am jGnucashEditor ist, dass er alle Konten, Rechnungen, Kunden und Aktienkurse berücksichtigt. Den download gibts hier und die englische Beschreibung gibts hier.

F: Gibt es einen Bericht für den monatlichen Vergleich der Erträge/Aufwendungen?

A: Ja, allerdings erfordert es einen Umweg über Budgets. Zunächst muss ein Budget für den entsprechenden Zeitraum mit monatlichen Budgetzeiträumen erstellt werden. Werte brauchen dafür allerdings nicht eingegeben werden, d.h. die voreingestellten Werte von 0 sind für diesen Zweck völig ausreichend. Wenn das Budget erstellt wurde, startet man Berichte->Budget->Budgetbericht. Unter Optionen->Anzeige stellt man dann ein, dass man "Ist anzeigen" will, "Budget anzeigen" wird deaktiviert. Der Bericht zeigt dann die monatlichen Ist-Aufwendungen.

Drucken

F: Wie kann ich die Schriftgröße zum Drucken von Berichten ändern?

A: Innerhalb von GnuCash habe ich keine Möglichkeit gefunden. Daher habe ich mir mit dem Export in eine Html-Datei und anschließender Konvertierung ins PDF-Format per htmldoc geholfen.

Ich wollte eine Kontenübersicht inkl. Bemerkungen drucken. Dabei wurden aber immer die hinteren Spalten abgeschnitten. Dies passierte auch, wenn ich den Bericht als html exportiert und dann den Ausdruck über den Browser durchgeführt habe. Daher habe ich das Programm htmldoc per sudo apt-get install htmldoc installiert und damit die Html-Datei in eine PDF-Datei umgewandelt. htmldoc erlaubt u.a. die Anpassung der Schriftart und -größe. Auch konnte ich hier die Verwendung des Querformates (Landscape) festlegen. Die PDF-Datei habe ich dann mit dem Acrobat-Reader ausgedruckt und auf die Art einen vollständigen Ausdruck ohne fehlende Spalten erhalten.

Hast Du schon mal Bearbeiten->Einstellungen->Drucken->Voreingestellte_Schriftgröße + Neustart ausprobiert?
Seit Version 2.6 kann GnuCash Berichte direkt als PDF ausgeben.

F: Wie kann ich Berichte in Querformat drucken?

A: Dies wird leider nicht unterstützt. Über den Umweg via HTML export geht das aber, mit hilfe von htmldoc. Beispielaufruf, bei der mehrere Einzelberichte in eine PDF zusammengesetzt werden:
htmldoc  -t pdf14 --webpage --no-links --linkstyle plain --size 297x210mm --headfootsize 9
--header fff -f bericht.pdf *.html

Import und Export

F: Wie kann ich den gesamten Kontenrahmen, aber ohne Buchungssätze exportieren?

A: Hier eine Anleitung:
  • eine leere Datei anlegen, der Name sowie die Endung sind dabei unwichtig.
  • Datei -> Export -> Konten exportieren.
  • nun die vorher angelegte Datei auswählen und Export drücken.
    • Um den leeren Kontenrahmen zu öffnen, einfach Datei -> öffnen und diese Datei auswählen.

F: Wie kann ich alle Buchungen nach Excel exportieren?

A: Siehe De/Bedienung#Export_von_Buchungen

F: Gibt es mittlerweile ELSTER-Unterstützung in Gnucash?

A: Nein, gibt es nicht. Zuletzt gab es auf gnucash-de im Januar 2005 noch Diskussionen dazu, siehe hier. Dort wurden mehrere Linux-Produkte erwähnt:
  • Unter Elster Online kann die Umsatzstuererkläung auch unter Linux abgegeben werden.


Im Geschäftseinsatz

Konten-Fragen

F: Gibt es einen Buchhalter in meiner Nähe, der GnuCash verwendet?

A: Wenn Sie Buchhalter sind, fügen Sie gerne hier Ihre Kontaktdaten ein.

Anpassungen und Einstellungen

OnlineBanking, HBCI und AqBanking

F: Ich habe einen Schlüssel (Keyfile) auf Diskette für ein anderes Programm bekommen. Leider funktioniert GnuCash nicht mit diesem Schlüssel?

A: Eine Schlüsseldatei eines fremden Programms funktioniert NICHT mit GnuCash!

F: Beim Absenden von Überweisungs- oder Lastschriftaufträgen kommt die Fehlermeldung HBCI: 9210 - DTA-Berechtigung fehlt (S)

A: AqBanking bietet die Wahlmöglichkeit, ob Aufträge entweder als Einzelaufträge (teurer) oder als Sammelaufträge (billiger, aber weniger Details im Kontoauszug) eingereicht werden. Diese Fehlermeldung besagt, dass man Sammelaufträge eingereicht hat, aber die Bank nur Einzelaufträge akzeptiert.
Abhilfe:
1. In der Datei ~/.banking/backends/aqhbci/settings.conf im Abschnitt für die entsprechende Bank und den
entspr. Benutzer: customer { [...] den Wert int preferSingleTransfer="0" auf int preferSingleTransfer="1" ändern.
2. Alternativ im Konfigurationsassistenten durchklicken zu "Users"/"Benutzer" -> <user wählen> -> "Expert Actions"/"Experten-Aktionen" -> "Edit"/"Bearbeiten" -> <Customer/Kunde wählen> -> | "Edit"/"Bearbeiten" -> "Prefer single Transactions over multi transfers"/"Einzelüberweisung anstelle Sammelüberweisung bevorzugen" aktivieren.

F: Wie kann man den Port angeben (bei Commerzbank Port 3000)?

A: Portnummer 3000 wird sowieso benutzt. Der Rechnername muss OHNE Portnummer angegeben werden, also einfach hbci.commerzbank.de. Bei HBCI-PIN/TAN wird eine Serveradresse (URL) wie im Browser angegeben und die kann auch eine Portnummer enthalten, z.B. https://rechner.com:1234/foo/bar

F: Die Bank nimmt meine Pin nicht an, woran kann das liegen?

Aus der Mailingliste: Ich versuche gerade GnuCash mit HBCI (PIN/TAN) für mein Volksbank-Konto einzurichten, leider scheitert es am Abrufen der Systemkennung.

16:07:40 AqHBCI gestartet
16:07:40 Mit Bank verbinden...
16:07:40 Ermittle Adresse von "hbci11.fiducia.de" ...
16:07:40 Ermittelte IP Adresse ist 195.200.36.155
16:07:41 Verbunden.
16:07:41 Aufträge werden kodiert
16:07:50 Antwort konnte nicht kodiert werden
16:07:50 Verbindung von Bank trennen...
16:07:50 Getrennt.
16:07:50 AqHBCI abgeschlossen.
16:07:50 Abgeschlossen. Sie können dieses Fenster nun schließen.
A: Das Problem lag wohl darin, dass ich neben numerischen Zeichen auch alphabetische drin hatte und die PIN länger als 5 Zeichen war. Irgendwie kapiert der Bankserver das dann wohl nicht. Nachdem ich meine PIN auf 5 Stellen gekürzt habe und nur noch Zahlen verwende, klappt auch die Verwaltung mit GnuCash.
Inzwischen akzeptiert HBCI (PIN/TAN) auch Buchstaben.

F: Woran merke ich, dass ich bei PIN/TAN die TAN falsch eingegeben habe?

A: Es gibt leider keine deutliche Rückmeldung. Man muss den Text im Logfenster durchlesen und dort auf entsprechende Meldungen achten. Siehe de/HBCI#Fehlende Rückmeldung nach falscher TAN.

F: Ich habe beim ersten Umsatzabruf versehentlich ein falsches Konto ausgewählt und kann das jetzt nicht mehr ändern. Wie kann ich das korrigieren?

A: Es gibt leider keine einfache Möglichkeit innerhalb von gnucash. Stattdessen muss man die XML-Datei per Hand im Texteditor ändern und diese gemerkte Auswahl dort löschen. Folgende Vorgehensweise:
  • In gnucash bei den Einstellungen unter Allgemein -> Datei -> "Datei komprimieren" das Häkchen wegnehmen, so dass die Datei also unkomprimiert gespeichert wird. Anschließend Datei speichern.
  • Gnucash beenden
  • Von der XML-Datei eine Sicherheitskopie beiseite legen, falls man sich im nächsten Schritt irgendwo vertippt
  • Die XML-Datei mit einem Texteditor öffnen. Auf Linux z.B. "gedit", auf Windows z.B. "Notepad++" oder "UltraEdit".
  • Im Texteditor nach Zeilen mit der Zeichenkette online_id (mit Unterstrich) suchen. Diese existiert bei jedem Konto, bei dem jemals irgendwas importiert wurde, sowohl über Online Banking oder OFX-Datei-Import. Man müsste nun diejenige Fundstelle finden, die innerhalb des gewünschten Bankkonto-Eintrags steht, oder andernfalls könnte man auch alle Fundstellen bearbeiten. Bei der gewünschten Fundstelle muss man nun im Texteditor die Zeilen unmittelbar um online_id herum löschen, und zwar von der Zeile mit dem Wort "slot" bis zur Zeile mit dem Wort "/slot", insgesamt vier Zeilen. Beispiel: Folgende vier Zeilen müsste man löschen:
<slot>
 <slot:key>online_id</slot:key>
 <slot:value type="string">20070024123456789</slot:value>
</slot>
(Hinweis: Die Kennung in der slot:value Zeile enthält die BLZ und Kontonummer für ein Online-Banking-Konto.)
  • Nachdem man diese vier Zeilen an den gewünschten Fundstellen gelöscht hat, speichere man die XML-Datei und beende den Texteditor.
  • Nun gnucash wieder starten und die Datei wieder öffnen. Sofern man nur diese vier Zeilen gelöscht hat und sonst nichts geändert hat, sollte gnucash augenscheinlich unverändert starten und insbesondere keine Fehlermeldung melden, wenn man die Datei öffnet. Falls Fehlermeldungen kommen, sollte man zur Sicherheitskopie der XML-Datei zurückkehren und hier von vorne beginnen.

Nun kann man einen neuen Umsatzabruf machen und wird dann wieder neu nach einem Konto gefragt. Außerdem kann man nun bei den Einstellungen unter Allgemein -> Datei -> "Datei komprimieren" den Haken wieder aktivieren, sofern man das möchte.

GnuCash Projekt

F: Wie kann ich Wünsche äußern?

A: Siehe Wie man einen Fehler meldet oder einen Verbesserungsvorschlag einreicht.
Daneben kann zur Strukturierung künftiger Projekte - Zusammentragen von rechtlichen und anderen Rahmenbedingungen etc. - die Projektseite verwendet werden.

Entwickler und andere Neugierige

F: Kann ich die Doxygen-Quelltextdokumentation auch offline lesen?

A: Wenn man die Quellen installiert hat, darin
make doc

aufrufen und anschließend src/doc/html/index.html öffnen.



F: GnuCash - Vorschlag für Datenschutz

A: Da momentan gnucash und die Daten noch nicht mit Passwort geschützt sind, hab ich mir gnucash auf ein verschlüsseltes Verzeichnis/Laufwerk installiert (T:\Banking). Da aber die Daten standardmäßig ins Homeverzeichnis gesichert werden (unter Windows meist nicht verschlüsselt)

habe ich den Startaufruf verändert:

bei mir in: t:\Banking\gnucash\bin\gnucash.cmd

setlocal
chcp 1252
set HOMEPATH=T:\Banking <== NEU **
set HOME=T:\Banking <== NEU **
set PATH=T:\Banking\gnucash\bin;T:\Banking\gnucash\lib;T:\Banking\gnucash\lib\gnucash;%PATH%
set GUILE_WARN_DEPRECATED=no
usw. 

Damit werden auch die abgerufenen Daten ins verschlüsselte Verzeichnis gespeichert.

Sofern man einen Zugriffsschutz wünscht, kann man hier dafür stimmen: Uservoice - Passwortschutz


Zurück zur Hauptseite